News
LockDown Browser Moodle Extension Update (Version 2020022400)
Posted by Respondus Support on 04 March 2020 09:42 AM

An update of the LockDown Browser Moodle Extension has been released: version 2020022400.

This update, which is installed by the administrator of a Moodle server, changes the LockDown Browser Dashboard such that it will no longer append the quiz title with “- Requires Respondus LockDown Browser”.  

The Moodle extension requires users to be running a version of LockDown Browser that is at least 2.0.4.04 (Windows) or 2.0.4.03 (Mac).  If your institution has labs or managed computers with older versions of the “Lab Edition” of LockDown Browser, do not install this Moodle extension until those computers are updated. (Note that the Student Edition of LockDown Browser automatically updates to the newest version, so this warning is only relevant to the Lab Edition.)

Administrators can obtain the updated integration by going to Respondus.com > Customer Login > LockDown Browser.  If there is more than one server profile for your institution, be sure to select the correct one before downloading the extension.